GWT - Upgrade to GWT 2.1 M1 and fix the module loading errors

If you try to use the just released GWT 2.1M1 library on your old projects you'll have some errors:

11:10:41.734 [ERROR] [gwt21m1test] Errors in 'jar:file:/C:/Borland/eclipse/plugins/com.google.gwt.eclipse.sdkbundle.2.1.0_2.1.0.m1-201005191217/gwt-2.1.0.M1/gwt-bikeshed.jar!/com/google/gwt/valuestore/ui/AbstractRecordListActivity.java'


11:10:41.796 [ERROR] [gwt21m1test] Line 89: No source code is available for type com.google.gwt.requestfactory.shared.Receiver; did you forget to inherit a required module?




To fix them add to your module .gwt.xml file the following line:

<inherits name='com.google.gwt.requestfactory.RequestFactory' />


Now your modules will load properly.

Cheers!

No comments:

Post a Comment